package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(\()(.*)(\))`)
var str = `rob(something)
bob (else ) here
john(fran
key ) and (this)
edward ( bob ) john
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}