re = /(.*)(\()(.*)(\))/m
str = 'rob(something)
bob (else ) here
john(fran
key ) and (this)
edward ( bob ) john
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end