using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/f\/.+?\/(?=$|page)";
string input = @"https://dev.site.by/catalog/vinilovoe-pokryitie/f/example/page/2/
https://dev.site.by/catalog/vinilovoe-pokryitie/f/example/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}