re = /\/f\/.+?\/(?=$|page)/m
str = 'https://dev.site.by/catalog/vinilovoe-pokryitie/f/example/page/2/
https://dev.site.by/catalog/vinilovoe-pokryitie/f/example/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end