$re = '/\/f\/.+?\/(?=$|page)/m';
$str = 'https://dev.site.by/catalog/vinilovoe-pokryitie/f/example/page/2/
https://dev.site.by/catalog/vinilovoe-pokryitie/f/example/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);