package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:1[89]|20)\b(*SKIP)(*F)|[^a-zA-Z\s]+`)
var str = `test 18 119 19 50 20 #@$@#%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}