re = /\b(?:1[89]|20)\b(*SKIP)(*F)|[^a-zA-Z\s]+/m
str = 'test 18 119 19 50 20 #@$@#%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end