$re = '/\b(?:1[89]|20)\b(*SKIP)(*F)|[^a-zA-Z\s]+/m';
$str = 'test 18 119 19 50 20 #@$@#%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);