using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{10}(?=\s)|(?<="")\d{10}(?="")";
string input = @"23436571545994641 INFO: ...
and
'{""deliveryDate"":""1545994641"",""error""...""}'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}