const regex = new RegExp('\\d{10}(?=\\s)|(?<=")\\d{10}(?=")', 'gm')
const str = `23436571545994641 INFO: ...
and
'{"deliveryDate":"1545994641","error"..."}'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}