using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3,}";
string input = @"Peugeot 306
Año 2017
20000 leguas de viaje submarino
1000000 de años luz
12 monos";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}