const regex = /\d{3,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{3,}', 'g')
const str = `Peugeot 306
Año 2017
20000 leguas de viaje submarino
1000000 de años luz
12 monos`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}