package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<mylevel>\w{4,5})`)
var str = `INFO - Service Started
DEBUG - Service suspended
hei what is my field
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}