#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im){IF\s*([^}]+)}([\s\S]+)(?:{\/?ELSE})([\s\S]+?){\/IF}"
Local $sString = "{IF !isLoggedIn}" & @CRLF & _
" <a href="/sign-in/">Sign In</a>" & @CRLF & _
"{ELSE}" & @CRLF & _
" Welcome back, {>username}!<br />" & @CRLF & _
" {# students}" & @CRLF & _
" <li>{#>last_name}, {#>first_name}</li>" & @CRLF & _
" {/#}" & @CRLF & _
"{/IF}" & @CRLF & _
"" & @CRLF & _
"{IF isLoggedIn}" & @CRLF & _
" Beta Testing..." & @CRLF & _
"" & @CRLF & _
"{/IF}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")