re = /{IF\s*([^}]+)}([\s\S]+)(?:{\/?ELSE})([\s\S]+?){\/IF}/im
str = '{IF !isLoggedIn}
<a href="/sign-in/">Sign In</a>
{ELSE}
Welcome back, {>username}!<br />
{# students}
<li>{#>last_name}, {#>first_name}</li>
{/#}
{/IF}
{IF isLoggedIn}
Beta Testing...
{/IF}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end