#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d\d:\d\d:\d\d.\d\d\d ;; \d\d:\d\d:\d\d.\d\d\d .*((?:\n(?!\d\d:\d\d:\d\d.\d\d\d ;; \d\d:\d\d:\d\d.\d\d\d).*)*)"
Local $sString = "00:00:09.476 ;; 00:00:11.111 side:start top:15% bottom:10% sound:80%" & @CRLF & _
"FOO BAR FOO FOO FOO BAR" & @CRLF & _
"" & @CRLF & _
"00:00:11.111 ;; 00:00:12.278 side:start top:15% bottom:10% sound:78%" & @CRLF & _
"BAR BAR BAR' BAR. FOO.BAR" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"00:00:12.278 ;; 00:00:14.447 side:start top:15% bottom:10% sound:43%" & @CRLF & _
"BOO.BOO. FARFAR.FAR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")