import re
regex = re.compile(r"^\d\d:\d\d:\d\d.\d\d\d ;; \d\d:\d\d:\d\d.\d\d\d .*((?:\n(?!\d\d:\d\d:\d\d.\d\d\d ;; \d\d:\d\d:\d\d.\d\d\d).*)*)", flags=re.MULTILINE)
test_str = ("00:00:09.476 ;; 00:00:11.111 side:start top:15% bottom:10% sound:80%\n"
"FOO BAR FOO FOO FOO BAR\n\n"
"00:00:11.111 ;; 00:00:12.278 side:start top:15% bottom:10% sound:78%\n"
"BAR BAR BAR' BAR. FOO.BAR\n"
"test\n\n\n"
"00:00:12.278 ;; 00:00:14.447 side:start top:15% bottom:10% sound:43%\n"
"BOO.BOO. FARFAR.FAR")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")