const regex = new RegExp('^\\d\\d:\\d\\d:\\d\\d.\\d\\d\\d ;; \\d\\d:\\d\\d:\\d\\d.\\d\\d\\d .*((?:\\n(?!\\d\\d:\\d\\d:\\d\\d.\\d\\d\\d ;; \\d\\d:\\d\\d:\\d\\d.\\d\\d\\d).*)*)', 'gm')
const str = `00:00:09.476 ;; 00:00:11.111 side:start top:15% bottom:10% sound:80%
FOO BAR FOO FOO FOO BAR
00:00:11.111 ;; 00:00:12.278 side:start top:15% bottom:10% sound:78%
BAR BAR BAR' BAR. FOO.BAR
test
00:00:12.278 ;; 00:00:14.447 side:start top:15% bottom:10% sound:43%
BOO.BOO. FARFAR.FAR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}