#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(?<directory_name>(?<template_name>[\w]+)[-\w]+)\/"
Local $sString = "/materio-vuetify-vuejs-admin-template/" & @CRLF & _
"/materio-vuetify-vuejs-admin-template/demo-1/dashboard-analytics" & @CRLF & _
"/materio-vuetify-vuejs-admin-template/demo-1/" & @CRLF & _
"/sneat-bootstrap-vue-admin-template/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")