const regex = /\/(?<directory_name>(?<template_name>[\w]+)[-\w]+)\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?<directory_name>(?<template_name>[\\w]+)[-\\w]+)\\\/', 'gm')
const str = `/materio-vuetify-vuejs-admin-template/
/materio-vuetify-vuejs-admin-template/demo-1/dashboard-analytics
/materio-vuetify-vuejs-admin-template/demo-1/
/sneat-bootstrap-vue-admin-template/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}