re = /\/(?<directory_name>(?<template_name>[\w]+)[-\w]+)\//m
str = '/materio-vuetify-vuejs-admin-template/
/materio-vuetify-vuejs-admin-template/demo-1/dashboard-analytics
/materio-vuetify-vuejs-admin-template/demo-1/
/sneat-bootstrap-vue-admin-template/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end