const regex = new RegExp('[\\u0021-\\u002f\\u003a-\\u0040\\u005b-\\u0060\\u007b-\\u008f\\u00a0-\\u00bf\\u00d7\\u00f7\\u2000-\\u2bff\\u3000-\\u303f]', 'gm')
const str = `-・·&%'・·關∞|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}