#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^arn:(?P<Partition>[^:\n]*):(?P<Service>[^:\n]*):(?P<Region>[^:\n]*):(?P<AccountID>[^:\n]*):(?P<Ignore>(?P<ResourceType>[^:\/\n]*)[:\/])?(?P<Resource>.*)$"
Local $sString = "# ARN Format Templates" & @CRLF & _
"arn:partition:service:region:account-id:resource" & @CRLF & _
"arn:partition:service:region:account-id:resourcetype/resource" & @CRLF & _
"arn:partition:service:region:account-id:resourcetype:resource" & @CRLF & _
"" & @CRLF & _
"# Amazon Simple Storage Service (S3)" & @CRLF & _
"arn:aws:s3:::my_corporate_bucket/Development/*" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")