import re
regex = re.compile(r"^arn:(?P<Partition>[^:\n]*):(?P<Service>[^:\n]*):(?P<Region>[^:\n]*):(?P<AccountID>[^:\n]*):(?P<Ignore>(?P<ResourceType>[^:\/\n]*)[:\/])?(?P<Resource>.*)$", flags=re.MULTILINE)
test_str = ("# ARN Format Templates\n"
"arn:partition:service:region:account-id:resource\n"
"arn:partition:service:region:account-id:resourcetype/resource\n"
"arn:partition:service:region:account-id:resourcetype:resource\n\n"
"# Amazon Simple Storage Service (S3)\n"
"arn:aws:s3:::my_corporate_bucket/Development/*\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")