#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)incorporation|\binc[.]*(?!\w)"
Local $sString = "Inc" & @CRLF & _
"Inc." & @CRLF & _
"Incorporation" & @CRLF & _
"My Inc" & @CRLF & _
"My Inc." & @CRLF & _
"My Inc. Company" & @CRLF & _
"My Incorporation company" & @CRLF & _
"Linc Communication Llc" & @CRLF & _
"DRV Incorporated"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")