import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "incorporation|\\binc[.]*(?!\\w)";
final String string = "Inc\n"
+ "Inc.\n"
+ "Incorporation\n"
+ "My Inc\n"
+ "My Inc.\n"
+ "My Inc. Company\n"
+ "My Incorporation company\n"
+ "Linc Communication Llc\n"
+ "DRV Incorporated";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}