const regex = new RegExp('incorporation|\\binc[.]*(?!\\w)', 'gmi')
const str = `Inc
Inc.
Incorporation
My Inc
My Inc.
My Inc. Company
My Incorporation company
Linc Communication Llc
DRV Incorporated`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}