#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^a-zA-Z0-9_,](?:\d{1,3},)*\d{1,3}\.\d\d\b"
Local $sString = "Hey Boss: " & @CRLF & _
"" & @CRLF & _
"Just so you know, I did all the crimes. Like 100 of them. So many crimes. " & @CRLF & _
"" & @CRLF & _
"We should probably delete this e-mail before we get sued." & @CRLF & _
"" & @CRLF & _
"xoxoxo," & @CRLF & _
"" & @CRLF & _
"Lackey." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Crime, INC." & @CRLF & _
"" & @CRLF & _
"For services rendered: " & @CRLF & _
"" & @CRLF & _
"Tax Fraud 100.00" & @CRLF & _
"" & @CRLF & _
"Price-fixing 9.99" & @CRLF & _
"" & @CRLF & _
"Insider trading 20.00" & @CRLF & _
"" & @CRLF & _
"TOTAL 129.99 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Here is a stupid number .00" & @CRLF & _
"" & @CRLF & _
"And here is another stupid number 1,000000,000.00" & @CRLF & _
"" & @CRLF & _
"Dear Boss:" & @CRLF & _
"" & @CRLF & _
"Remember all those crimes I've committed? They made the firm $1,280,012.05. Maybe a raise?" & @CRLF & _
"" & @CRLF & _
"xoxoxo," & @CRLF & _
"" & @CRLF & _
"Lackey" & @CRLF & _
"" & @CRLF & _
"p.s. Here's a large dollar amount that also would not have matched the previous regex, but will match the new one!: 1,000,000,000,000.00 " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")