const regex = /^[A-Z][a-z]*(([,.] |[ '-])[A-Za-z][a-z]*)*(\.?)( [IVXLCDM]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z][a-z]*(([,.] |[ \'-])[A-Za-z][a-z]*)*(\\.?)( [IVXLCDM]+)?$', 'gm')
const str = `Dr. Ronaldo Jr. VII
Robert D'Costa
Robert d'Costa
Robert D'costa
Robert d'costa
Try As many as you want Below This.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}