$re = '/^[A-Z][a-z]*(([,.] |[ \'-])[A-Za-z][a-z]*)*(\.?)( [IVXLCDM]+)?$/m';
$str = 'Dr. Ronaldo Jr. VII
Robert D\'Costa
Robert d\'Costa
Robert D\'costa
Robert d\'costa
Try As many as you want Below This.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);