re = /^[A-Z][a-z]*(([,.] |[ '-])[A-Za-z][a-z]*)*(\.?)( [IVXLCDM]+)?$/m
str = 'Dr. Ronaldo Jr. VII
Robert D\'Costa
Robert d\'Costa
Robert D\'costa
Robert d\'costa
Try As many as you want Below This.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end