const regex = /^([^;]*;){10}\d\s(?P<Field1>\d)\s(?P<Field2>\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^;]*;){10}\\d\\s(?P<Field1>\\d)\\s(?P<Field2>\\d)', 'gm')
const str = ` 2019-05-02 07:26:07.283;2019-05-02 05:26:07.283;2019-05-02 07:26:07.283;LOOKINGFORACTION;TO;SOMESTRING;FROM;SOMESTRING;MSG [223];\\x00;0 2 2 0 0 0 0 0 8 0 0 0 0 0 0 0 2 FC 3E ;\\x00;\\x00;\\x00;0;0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}