re = /^([^;]*;){10}\d\s(?P<Field1>\d)\s(?P<Field2>\d)/m
str = ' 2019-05-02 07:26:07.283;2019-05-02 05:26:07.283;2019-05-02 07:26:07.283;LOOKINGFORACTION;TO;SOMESTRING;FROM;SOMESTRING;MSG [223];\\x00;0 2 2 0 0 0 0 0 8 0 0 0 0 0 0 0 2 FC 3E ;\\x00;\\x00;\\x00;0;0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end