use strict;
my $str = ' 2019-05-02 07:26:07.283;2019-05-02 05:26:07.283;2019-05-02 07:26:07.283;LOOKINGFORACTION;TO;SOMESTRING;FROM;SOMESTRING;MSG [223];\\x00;0 2 2 0 0 0 0 0 8 0 0 0 0 0 0 0 2 FC 3E ;\\x00;\\x00;\\x00;0;0';
my $regex = qr/^([^;]*;){10}\d\s(?P<Field1>\d)\s(?P<Field2>\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}