#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^#(?:00(?:FF[a-fA-F0-9]{2}|[a-fA-F0-9]{2}FF)|FF(?:00[a-fA-F0-9]{2}|[a-fA-F0-9]{2}00)|[a-fA-F0-9]{2}(?:00FF|FF00))$"
Local $sString = "#FF00AD" & @CRLF & _
"#00FFFD" & @CRLF & _
"#0023FF" & @CRLF & _
"#E300FF" & @CRLF & _
"#B4FF00" & @CRLF & _
"#FFCC00" & @CRLF & _
"" & @CRLF & _
"#FF0000" & @CRLF & _
"#FFFFFF" & @CRLF & _
"#456789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")