$re = '/^#(?:00(?:FF[a-fA-F0-9]{2}|[a-fA-F0-9]{2}FF)|FF(?:00[a-fA-F0-9]{2}|[a-fA-F0-9]{2}00)|[a-fA-F0-9]{2}(?:00FF|FF00))$/m';
$str = '#FF00AD
#00FFFD
#0023FF
#E300FF
#B4FF00
#FFCC00
#FF0000
#FFFFFF
#456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);