package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#(?:00(?:FF[a-fA-F0-9]{2}|[a-fA-F0-9]{2}FF)|FF(?:00[a-fA-F0-9]{2}|[a-fA-F0-9]{2}00)|[a-fA-F0-9]{2}(?:00FF|FF00))$`)
var str = `#FF00AD
#00FFFD
#0023FF
#E300FF
#B4FF00
#FFCC00
#FF0000
#FFFFFF
#456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}