#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:^|\R)(?!.*\bEXCLUDE\b).*)+"
Local $sString = "First include this line" & @CRLF & _
"EXCLUDE this entire line" & @CRLF & _
"include this line" & @CRLF & _
"and this as single match" & @CRLF & _
"and EXCLUDE this line" & @CRLF & _
"Lastly include this line"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")