re = /(?:(?:^|\R)(?!.*\bEXCLUDE\b).*)+/m
str = 'First include this line
EXCLUDE this entire line
include this line
and this as single match
and EXCLUDE this line
Lastly include this line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end