$re = '/(?:(?:^|\R)(?!.*\bEXCLUDE\b).*)+/m';
$str = 'First include this line
EXCLUDE this entire line
include this line
and this as single match
and EXCLUDE this line
Lastly include this line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);