using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(test1 (((?!test2).)*)$)|(^(((?<!test1).)*)test2)";
string input = @"test1 anything here
anything here test2
test1 anything here test2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}