re = /(test1 (((?!test2).)*)$)|(^(((?<!test1).)*)test2)/m
str = 'test1 anything here
anything here test2
test1 anything here test2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end