$re = '/(test1 (((?!test2).)*)$)|(^(((?<!test1).)*)test2)/m';
$str = 'test1 anything here
anything here test2
test1 anything here test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);