using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([a-zA-Z]+) is \1\b";
string input = @"sue-ann is ann-marie
x anna is anna y
anna is ann
anna is anne
anna is annabelle
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}