$re = '/\b([a-zA-Z]+) is \1\b/m';
$str = 'sue-ann is ann-marie
x anna is anna y
anna is ann
anna is anne
anna is annabelle
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);