const regex = /\b([a-zA-Z]+) is \1\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([a-zA-Z]+) is \\1\\b', 'gm')
const str = `sue-ann is ann-marie
x anna is anna y
anna is ann
anna is anne
anna is annabelle
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}