using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\n\n).+(?=\n\n)";
string input = @"The time will come when, with elation, you will greet yourself arriving at your own door, in your own mirror, and each will smile at the other's welcome, and say, sit here. Eat. You will love again the stranger who was your self. Give wine. Give bread. Give back your heart to itself, to the stranger who has loved you
all your life, whom you ignored for another, who knows you by heart. Take down the love letters from the bookshelf,
the photographs, the desperate notes, peel your own image from the mirror. Sit. Feast on your life.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}