import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\n\\n).+(?=\\n\\n)";
final String string = "The time will come when, with elation, you will greet yourself arriving at your own door, in your own mirror, and each will smile at the other's welcome, and say, sit here. Eat. You will love again the stranger who was your self. Give wine. Give bread. Give back your heart to itself, to the stranger who has loved you\n\n"
+ "all your life, whom you ignored for another, who knows you by heart. Take down the love letters from the bookshelf,\n\n"
+ "the photographs, the desperate notes, peel your own image from the mirror. Sit. Feast on your life.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}