const regex = /\w{3,}\b(?!\()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w{3,}\\b(?!\\()', 'gm')
const str = `T.name.other_name.another_name
T.name.again_name.ect_name.last_name()`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}