use strict;
my $str = '232565898745612';
my $regex = qr/(^\d{5})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";